+ Reply to Thread
Results 1 to 4 of 4
  1. #1
    Guest

    Engine runs after I turn it off

    I have had my 2005 Manual transmission civic Hybrid for 2 weeks. Sometimes after I turn the engine off, get out of the car, lock it up, and start walking away, I hear the engine still running. The purr is coming from the front of the car, so I do not believe it is just the fan, which is supposed to be in the rear? Once I waited 5 minutes for it to turn off and it didn't. I always have to get back in the car, start the engine and turn it off again to get it to stop running.

  2. Remove Advertisements
    HybridCars.com
    Advertisements
     

  3. #2
    Guest

    Engine runs after I turn it off

    It's the fan. I have had other non-hybrids which ran the fan after the car turns off; on my honda civic hybrid it is just more pronounced.

    Sometimes it stays on for a few minutes, cooling the engine and (I imagine) the eletric motor.

    It's nothing to worry about, unless it *never* turns off, or runs for well more than 5 minutes. If this was the case, I would take it in to your dealer.

  4. #3
    Guest

    Engine runs after I turn it off

    I agree. I have a 2004 Civic Hybrid and the fan does tend to come on for a few minutes after the engine is turned off, especially in warmer weather. Older cars tended to have large front grills that allowed a great deal of air to blow over/through the radiator. This helped to reduce the temperature of the coolant. Newer cars have little or no grill facia and so no appreciable air hits the radiator. The fan cools the radiator from behind and can run from about 30 seconds to about five minutes depending on how hot the engine is.

  5. #4
    Guest

    Engine runs after I turn it off

    Hi

    I have a skoda felica and my fan does not come on when the engine starts. The fan does work. How do I know, well I can plug in little red wire and the fan starts working, but to turn it off I have to disconnect it. There is no wires comeing from the radiator so I guess the regulator has not been connnected. Any ideas?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts