+ Reply to Thread
Results 1 to 1 of 1
  1. #1
    Junior Member
    Join Date
    Sep 2016
    Posts
    1

    2007 Honda Civic Hybrid - IMA battery replaced, light came back on

    Alright, sparing no detail here.

    I bought a used 2007 HCH at 107K miles. Less than 72 hours after purchase (as is from used car dealer) IMA and check engine light come on and living in a fairly hilly city I could tell that it wasnt a false alarm as I could barely get uphill at all, but still decided to get it coded at a honda dealership to verify it was the only issue. Dealer confirms IMA replacement, so I order one and install it myself with no issue. Everythings good, got lots more power, no issues for a few days then for whatever reason my regular 12 V battery doesnt have enough juice to start the car. Jump it and it starts right up, easy fix. After the 3rd day in a row where I had to jump it I decide to go ahead and replace the 12V battery, now theres no issue starting. Good good, all is well. 2 days after installing the new 12 V battery I was driving it around and all the sudden the check engine and IMA light click on again, but I definitely can still handle the hills and no noticeable power issues. Any thoughts on this?
    Last edited by spearsns; 09-13-2016 at 04:42 AM. Reason: OCD

  2. Remove Advertisements
    HybridCars.com
    Advertisements
     

+ Reply to Thread

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts