+ Reply to Thread
Results 1 to 10 of 406

Hybrid View

  1. #1

    Civic Hybrid Battery IMA Problems

    I have a 2007 HCH with 34,000 miles that has become unpredicable, unreliable and unsafe - and Honda knows about the problem but chooses not to fix it. The battery, especially after being in the heat, suddenly drops to no or one bar and the battery stops providing any assistance and won't charge properly either.

    I can only guess it would cost too much to replace the battery and they have made a business decision not to fix my car. My car is driven in Florida, and as other posts here note, the batteries seem to be damaged by our summertime heat (I note the new Prius has a little solar panel that drives a small fan to keep the cabin (and battery pack?) cooler than the 100+ a car quickly heats to when parked in the Florida sun).

    My local Honda Service Manager has told me this is a known problem and Honda doesn't know how to fix. He went on to say how frustrated he is because he has already lost three customers due to the problem. He also told me that he is not allowed to order me a new battery, even if he wanted to, without American Honda approval. He suggested there was nothing else he could do and I should contract American Honda Customer Service, which I did. They did not call me back for over a week and when they did, they asked for a couple of days more since they needed to talk to the dealer. Customer Service?

    Does anyone know of a fix?

    Has anyone who's had this problem had is satisfactorly dealt with by American Honda?

    Does anyone know of a good class action lawyer.

    DON'T BUY HONDA CIVIC HYBRID - BATTERIES ARE SERIOUSLY FLAWED AND WILL LEAVE YOU FINANCIALLY "SCREWED" SINCE YOU CAN'T SELL THE POORLY RUNNING CAR AND YOU CAN'T DRIVE IT EITHER.

  2. #2
    Junior Member
    Join Date
    Nov 2014
    Posts
    1
    Im getting 10l/100km on my Hybrid ? i reset the meter and got this reading for the 150km ... this is 10km/L about half the advertised efficiency.. temperature is -10 celcius mostly and never crossing 1500 RPM no matter what... im just baffled. 154KM and brought it second hand

  3. #3
    Junior Member
    Join Date
    Jan 2015
    Posts
    1
    I am yet another victim after just 29000 miles, it started when the car did not start and I had to change the regular battery, soon after the IMA light came on after every 40 km and it goes off when you stop the engine and comes on again after about 40km, I took it to honda and they said the IMA came on because I had removed the regular battery without a back up 5volt battery connection which i was clueless about, now they say the IMA is not charging at its regular 60 or 70% instead the charge is only 4% though the auto stop is effective. Can someone please help me out as i cannot afford to buy a new battery. I will be very thankful if any one who has got out from a similar experience or someone with a mechanical background to help me as the guys at Honda care a dam about the problem although they say their motto is to make the customer happy???

+ Reply to Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts