+ Reply to Thread
Results 1 to 9 of 9
  1. #1
    Junior Member
    Join Date
    Mar 2008
    Posts
    0

    FEH NAV date syndrome, by design or bug

    Hi All:

    I'm trying to collect some real data here from owners of 2008/2009 Ford Escape Hybrids, Mercury Mariner owners may chime in as well.

    With vehicles with the NAV system installed, there are reports that all 2009 units fail to continue to show the date in the center stack display when the radio is turned on, There are reports of the time actually hanging (stuck) in the center while the real time is displayed in the upper right hand corner durning media changes.

    I'd like to know if you owners are experiencing this issue.

    I would like to know the year and model of the vehicle as well as the configuration of the entertainment system, either the NAV system or the 6 disc changer system. as well as wether you have seen this issue or not. This might allow me to figure out if this is by design or a bug and perhaps a fix can be put in order.

    -paul


  2. Remove Advertisements
    HybridCars.com
    Advertisements
     

  3. #2
    Junior Member
    Join Date
    May 2008
    Posts
    0

    09 MMH. The "Next Generation

    09 MMH. The "Next Generation Navigation" system (the one with the outdated mapping and POI software) does eliminate the date info from the center console when the radio is on.

    I have not noticed the stuck time problem.



  4. #3
    Junior Member
    Join Date
    Mar 2008
    Posts
    0

    Thanks for the comment back,

    Thanks for the comment back, yes, I have noticed the outdated maps. I am currently working with Ford on the date issue, but am going to mention that the maps need updating since it has no idea where I live.

    Abvout the date hang, before you turn off your car, turn the radio off, then turn off the car, then start the car and side in a CD, you will then see the double clock, one in the center that is stuck and one in the upper right.

    There's no damage, I'm just trying to get to the end of it.

  5. #4
    Junior Member
    Join Date
    May 2008
    Posts
    0

    I just discovered how really

    I just discovered how really shameful the "Next Generation" system is (in addition to yesteryear's map data):

    The nav itself has very flawed logic. I was in a parking lot of a movie theater last night, used the Sirius Sync movie listings feature to look for the theater and was informed that it was 14 miles away. I selected the theater as a destination and a route was calculated that totaled 39 miles, including US Forest service roads, 35% dirt roads with no names and a trip up and down a 6000 ft mountain. All this to get to where I was already at.

    Thinking that the system may have been confused by my seeking to navigate to my current location, I drove 3 miles away, tried again and got the same result (which now included driving by the destination theater).

    Very disappointing. It is a shame that FoMoCo disseminates such a flawed system. It sours my overall perception of the 09 MMH I was so happy to finally acquire.

  6. #5
    Guest

    I just finally received my

    I just finally received my 2009 FEH. I have the Nav system and I've been looking all over the net for info on why my time/date doesn't show up when my radio is on. As far as outdated maps go, Milwaukee just finished rebuilding a major interchange in August 2008. They reconfigured it adding/removing off ramps and moved all left exits to the right side. My maps show the new configuration.

  7. #6
    Guest

    I just bought my new 2009

    I just bought my new 2009 Escape Hybrid a week ago. I definitely have the same clock issue. With the radio off, the time shows on the top LED display. With it on, I only see am or pm. It never shows in the NAV unit, which it is supposed to. I am also working with my dealer, but they dont have answers from Ford Corp yet. As far as maps, I have found mine VERY accurate...much more so than my Toyota Prius. Perhaps there is an updated DVD that I have, which others do not. If you go to the i button, you'll find it there. I have version number 1.0x. I doubt it matters, but it also reports Application number RMJ1-SMTW.

  8. #7
    Guest

    Ok...everyone will be happy

    Ok...everyone will be happy to know there is a fix for the missing clock issue!!! Mine is working great now. The computer just needs to be reprogrammed. Any dealer can do it. Of course, if your dealer gives you a dumb look when you say fix it, I can help you there, too. The problem is in their TIS database and there is a TSB (Technical Service Bulletin) that your dealer can pull up which explains the exact procedure for reprogramming the computer. Tell your dealer to look up TSB # 20668. How is that for specific information...:-). The upper display will show the time only with the radio on. If the radio is off, it will show time and date. Here is another cool feature. If the Escape is turned off, push the volume knob and the time will show up on the lower touch screen. Enjoy guys!!! By the way, Sync Support were the only folks knowledgeable enough to help. These folks were GREAT to work with. Its nice to see some real customer service. You can find the number by pushing the i button and going to the System tab.

  9. #8
    Guest

    [url=http://www.natiga-thanwy


  10. #9
    Guest

    I have noticed the hung time

    I have noticed the hung time issue - it shows the hung time in the middle of the center stack above the date - the correct date is shown in the upper right corner of the stack. It does fail to show the date while the radio is on.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts